Root/debian/rules

Source at commit 680e64d418149058a7edbe5adda37c3180b1f477 created 13 years 5 months ago.
By Xiangfu Liu, add debian package stuff add ITP bug number to 'debian/changelog'
1#!/usr/bin/make -f
2
3include /usr/share/cdbs/1/rules/debhelper.mk
4include /usr/share/cdbs/1/class/autotools.mk
5
6DEB_INSTALL_MANPAGES_dfu-util := doc/dfu-util.1
7
8# We must first call ./autogen.sh to generate the autotools stuff.
9post-patches:: debian/stamp-autothings-update
10debian/stamp-autothings-update:
11    @#aclocal
12    @#autoheader
13    @#automake --foreign --add-missing --copy
14    @#autoconf
15    ./autogen.sh
16    touch $@
17
18# Do not install the dfu-util_static binary, it's not needed in Debian.
19binary-post-install/dfu-util::
20    rm -f debian/dfu-util/usr/bin/dfu-util_static
21
22clean::
23    rm -f debian/stamp-autothings-update
24    @# Delete generated files, we don't want them in the diff.
25    rm -f aclocal.m4 config.h.in configure Makefile.in m4/install-sh
26    rm -f m4/missing m4/depcomp src/Makefile.in src/dfu-version.h
27
28

Archive Download this file

Branches:
master



interactive