Root/debian/rules

Source at commit d76f7d19a894bcf90fe5118c8573549ebf9d56d0 created 11 years 5 months ago.
By Xiangfu, debian: cleanup changelog, include debian build flags
1#!/usr/bin/make -f
2# This file is in the public domain.
3# You may freely use, modify, distribute, and relicense it.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8DPKG_EXPORT_BUILDFLAGS = 1
9include /usr/share/dpkg/buildflags.mk
10
11export PREFIX=/usr
12
13%:
14    dh $@
15
16override_dh_auto_clean:
17    $(MAKE) spotless
18    sh debian/clean.sh
19
20override_dh_installchangelogs:
21    dpkg-parsechangelog --format rfc822 --all | \
22        awk -f debian/changelog.upstream.awk
23    dh_installchangelogs debian/changelog.upstream
24
25REPO = git://projects.qi-hardware.com/fped.git
26BRANCH = master
27get-orig-source:
28    REPO='$(REPO)' BRANCH='$(BRANCH)' \
29        sh ./debian/get-orig-source.sh
30
31

Archive Download this file

Branches:
master



interactive