gmenu2x

Sign in or create your account | Project List | Help

Issue 92: icons don't display correctly

Reported by zear, Sep 9, 2010

Gmenu2x has a feature of associating icons to the filename. So for 
example, if your program's executable is called foo.dge, gmenu2x 
looks for an icon file foo.png in the same dir. If it finds it, it 
sets it as an icon. It works like that with joyrider's gmenu2x build 
for dingux and I also believe it works like that with my original 
gmenu2x build for the nanonote. However with GIT build, this feature 
is missing/not working. I also noticed that you can't set a custom 
icon via gmenu2x gui dialog, so that might be also related.
The only way to make icons work with the current GIT version is to 
manually edit the config for each entry and add the ICON= line.

Comment 1 by Maarten ter Huurne, Sep 19, 2011

With today's build I cannot reproduce this issue. Note that we only 
support PNG files nowadays, not whatever formats SDL_image was 
compiled for. So if you have icons in BMP or JPEG format, please 
convert them to PNG.

Comment 2 by Maarten ter Huurne, Aug 12, 2013

Assuming problem no longer exists in current code. If not, please 
re-open.
Status: Invalid

Created: 9 years 7 months ago by zear

Updated: 6 years 7 months ago

Status: Invalid

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect



interactive