Date:2009-08-05 02:09:27 (10 years 9 months ago)
Author:ZhangJieJing
Commit:4d4837484aaf20de156270a9f2bb0b65fb8c01ad
Message:autoconf: add error message when check lib usb and confuse failed. And prompts user to install the lib.

Signed-off-by: JieJing.Zhang <kzjeef@gmail.com>
Files: usbboot/configure.ac (1 diff)

Change Details

usbboot/configure.ac
1515
1616# Checks for libraries.
1717AC_CHECK_LIB([c], [main])
18AC_CHECK_LIB([confuse], [main])
18AC_CHECK_LIB([confuse], [main], [], [
19echo "Error! You need to have libconfuse."
20echo "Maybe run 'sudo apt-get install libconfuse-dev' under debian"
21exit -1 ])
1922AC_CHECK_LIB([gcc], [main])
2023AC_CHECK_LIB([m], [main])
21AC_CHECK_LIB([usb], [main])
24AC_CHECK_LIB([usb], [main], [], [
25echo "Error! You need to have libconfuse. \n"
26echo "Maybe run 'sudo apt-get install libusb-dev' under debian"
27exit -1 ])
2228
2329LIBS="$LIBS $USB_LIBS"
2430CFLAGS="$CFLAGS $USB_CFLAGS"

Archive Download the corresponding diff file



interactive