Root/INSTALL

1Build Requirements: libusb-dev, libconfuse-dev
2  This requires a mipsel-openwrt-linux- cross-toolchain in your $PATH. You
3  can get one by building the development environment from Qi Hardware, for
4  example.
5
6    git://projects.qi-hardware.com/openwrt-xburst.git xburst
7
8  See the Qi Hardware wiki for details.
9
10    http://en.qi-hardware.com/wiki/Building_Software_Image
11
12Build and Installation:
13  git submodule update --init
14  ./autogen.sh
15  ./configure --enable-firmware CROSS_COMPILE=mipsel-openwrt-linux- --prefix=/usr --sysconfdir=/etc
16  make
17  make install
18    *) make install will install the 'usbboot' and 'xbboot' binary to /usr/bin/usbboot,
19       target stages to /usr/share/xburst-tools/, usbboot configure file 'usbboot.cfg'
20       file into /etc/xburst-tools.
21
22Buile Debian Package:
23  Please read debian/README.source
24
25Create Source tarball, for example, version is: '201007'
26  git archive -v --format=tar 201007 | bzip2 > ../xburst-tools_201007.tar.bz2
27

Archive Download this file



interactive